Ncurses and env problems

Filip Joelsson filip at blueturtle.a.se
Fri Oct 13 17:24:55 PDT 2000


Hello!

I'm currently doing my second LFS system (did the first one on 2.2).

The problems (not counting the ones introduced by my typos ;) started with chroot. My system (RH6.2) complained about env being missing, when I passed it to chroot like this:
chroot /lfs env -i HOME=/root bash --login

When I tried just:
env -i HOME=/root bash --login
it worked like a charm.

And when I did:
chroot $LFS bash --login -i
it worked too.

So I settled for chroot'ing without env, and everything worked for a while. But then, when I got to the ncurses installation, I got an error about strstream.h being missing. So I went hunting, and I found it in /usr/include/g++-2 in the chroot'ed environment; same as on the RH system. So, I tried adding that dir to the PATH, but the compile quit with the same error again.

So, my question is if this error has anything to do with my not succeeding with env, or if the two problems are unrelated. Or should I just copy the headers in /usr/include/g++-2 into /usr/include?

TIA!
/Filip


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list