Ncurses and env problems

Gerard Beekmans gerard at linuxfromscratch.org
Tue Oct 17 12:08:06 PDT 2000


On Fri, 13 Oct 2000, you wrote:
> Hello!
>
> I'm currently doing my second LFS system (did the first one on 2.2).
>
> The problems (not counting the ones introduced by my typos ;) started with
> chroot. My system (RH6.2) complained about env being missing, when I passed
> it to chroot like this: chroot /lfs env -i HOME=/root bash --login
>
> When I tried just:
> env -i HOME=/root bash --login
> it worked like a charm.

There's a slight error here:
when chroot /lfs env failed it meant that there was no 'env' program in 
$LFS/bin or $LFS/usr/bin

the fact that env -i... worked (without chroot) means that the program was 
present on RedHat. We're looking at different env programs.

So check if $LFS/usr/bin/env is present and if so, make sure it's statically 
linked at this point by running ldd $LFS/usr/bin/env

> So I settled for chroot'ing without env, and everything worked for a while.
> But then, when I got to the ncurses installation, I got an error about
> strstream.h being missing. So I went hunting, and I found it in
> /usr/include/g++-2 in the chroot'ed environment; same as on the RH system.
> So, I tried adding that dir to the PATH, but the compile quit with the same
> error again.

Try this:
enter chroot
cd /usr/lib
ln -s g++-2 g++

Try compiling again.


-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list