problems making make

Matthias Benkmann mbenkmann at gmx.de
Sat Oct 21 12:40:06 PDT 2000


> > I have stripped __environ from libc.a:environ.o and compilation works and 
> > make check passes all tests. Does anybody know if I have to expect 
> > problems with this fix.
> 
> Oops. I messed something up. This fix worked for the shellutils (where I 
> had the same error). Make, however, still fails at some checks 
> (parallelism for instance) even though the compiler error disappeared. Any 
> ideas?

Sorry, for cluttering up the list with my messages. I have found the 
problem. Before making glibc I had to look desperately for the necessary 
MBytes on my hard disk and I stripped my /usr/bin, /usr/lib,... 
I used "--strip-unneeded" to get as many bytes stripped as possible but it 
seems that strip's idea of what's "unneeded" is not 100% correct (does 
anyone know why? Is it a bug or do I misunderstand the --strip-unneeded 
option?). I reinstalled the library files from my distribution CD and now 
it works fine. 

MSB

----
Ambition is a poor excuse for not having enough sense to be lazy.


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list