can't make ld.so on ppc

Jesse McCrosky mccrosky at ualberta.ca
Tue Sep 12 18:36:45 PDT 2000


	Three answers to that!  The system I am building my LFS from is based
on 2.2.15pre3 but is actually being booted from 2.2.15pre19.  The kernel
I have (partially) installed on my LFS system is 2.2.17.

	jesse

Gerard Beekmans wrote:
> 
> > In file included from /usr/include/linux/elf.h:5,
> >                  from ldd.c:27:
> > /usr/include/asm/elf.h:43: parse error before `elf_vrreg_t'
> > /usr/include/asm/elf.h:43: warning: data definition has no type or
> > storage class
> > /usr/include/asm/elf.h:44: parse error before `elf_vrregset_t'
> > /usr/include/asm/elf.h:44: warning: data definition has no type or
> > storage class
> > ldd.c: In function `main':
> > ldd.c:188: warning: implicit declaration of function `uselib'
> > make: *** [ldd.o] Error 1
> 
> Which kernel version are you using?
> 
> --
> Gerard Beekmans
> www.linuxfromscratch.org
> 
> -*- If Linux doesn't have the solution, you have the wrong problem -*-





More information about the lfs-dev mailing list