can't make ld.so on ppc

Jesse McCrosky mccrosky at ualberta.ca
Tue Sep 12 19:07:30 PDT 2000


	Perhaps, I was unclear.  The kernel in $lfs/usr/src/linux is 2.2.17.   
So, unless you can think of some other possible problem I think I can
confirm that ld.so-1.9.9 is incompatable with linux-2.2.17.  I decided
to go with 2.2.17 as it, apparently, provides much better support for
newer powerpc hardware including usb. Is ld.so a necessary package?  If
so, is a new version available?  Thank you for all your help.

	jesse

Gerard Beekmans wrote:
> 
> On Tue, 12 Sep 2000, you wrote:
> > Three answers to that!  The system I am building my LFS from is based
> > on 2.2.15pre3 but is actually being booted from 2.2.15pre19.  The kernel
> > I have (partially) installed on my LFS system is 2.2.17.
> 
> The reason I asked is that the package is having problems with your kernel
> headers (the asm ones).
> 
> Perhaps you better get rid of whatever is in $LFS/usr/src/linux, download the
> 2.2.17 kernel (though i haven't tested 2.2.17 yet so if you want to be on the
> safe side use 2.2.16 or wait till somebody else here confirms that 2.2.17
> works with ld.so) and put that on on your LFS partition. Then enter chroot
> again and try ld.so again. It should work now.
> 
> --
> Gerard Beekmans
> www.linuxfromscratch.org
> 
> -*- If Linux doesn't have the solution, you have the wrong problem -*-





More information about the lfs-dev mailing list