gcc problem in chroot

Patrick Buckles dsc222 at hotmail.com
Wed Sep 20 23:05:42 PDT 2000


Well Chris,

I had the same exact problem, and unfortunately, the reason why mine didn't 
work was this: The problem actually had to do with the first compile of GCC, 
before the chroot.  I had problems with the first install of GCC, and I had 
to keep re-typing the make command, and it wasn't fully compiling GCC.  I 
couldn't get through the actual compilation of GCC without re-typing the 
make line about 50 times.  It finally finished, but I went to chroot, and it 
gave me the exact same error, including the gcc-pc-linux-gnuld.  Mine had 
the extra ld at the end also.  It all came down to having bad RAM.  I 
installed a good 256 meg dimm, it compiled GCC fine outside of chroot, and 
when I chroot'd it worked perfect.  You might want to look into that.

Patrick Buckles AKA DSC22
dsc222 at hotmail.com


>From: chris <ccasey at mac.com>
>Reply-To: lfs-discuss at linuxfromscratch.org
>To: lfs-discuss at linuxfromscratch.org
>Subject: gcc problem in chroot
>Date: Wed, 20 Sep 2000 13:50:22 -0500
>
>when trying to compile gcc in the chrooted directory, I get the following 
>error:
>
>Configuring for a i586-pc-linux-gnuoldld host.
>Created "Makefile" in /usr/src/gcc-build using "mh-frag" and "mt-frag"
>gcc: installation problem, cannot exec `as': No such file or directory
>*** The command 'gcc -o conftest -O3 -mcpu=i386 -march=i386   conftest.c' 
>failed.
>*** You must set the environment variable CC to a working compiler.
>
>I checked /usr/bin & cc does point to gcc, & I didn't find anything in the
>archives.  I also tried -O2, -O, & no optimization with essentially the 
>same
>error (that is the letter O & not the number zero, correct?)
>
>thanks for any help
>
>Chris
>
>

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.






More information about the lfs-dev mailing list