glibc segmentation fault

Kyle West sithii at hotmail.com
Fri Sep 22 08:18:30 PDT 2000


Yes, it was nasty.  I did not try what you suggested below because last 
night as I was attempting to sleep, I thought of one small thing I had 
overlooked...

When I was compiling the first LFS, I made the root bash profile changes for 
CFLAGS, CXXFLAGS and TERM that you had suggested.  When I went to compile 
the 2nd LFS, it was still loading the bash profile from root, since now 
everytime I log in as root those are set.  So, I completely whiped out my 
'problem' copy of glibc, cleared those 3 variables, and compiled glibc 
again, this time without a problem.  (YAY!)

I was kind of tipped off to it by your comment on the ld.so package that 
ld.so sometimes has difficulty compiling with optimization settings, and it 
would appear to me that glibc has an internal ld.so that it uses and is 
subject to the same compilation difficulties.

So, YAY!  Problem solved.

>From: Gerard Beekmans <gerard at linuxfromscratch.org>
>Reply-To: lfs-discuss at linuxfromscratch.org
>To: lfs-discuss at linuxfromscratch.org
>Subject: Re: glibc segmentation fault
>Date: Fri, 22 Sep 2000 08:21:05 -0400
>MIME-Version: 1.0
>Received: from [216.29.174.31] by hotmail.com (3.2) with ESMTP id 
>MHotMailBB94999D00AED82197E9D81DAE1F10170; Fri Sep 22 05:20:46 2000
>Received: from shadowfax (localhost.localdomain [127.0.0.1])by 
>shadowfax.linuxfromscratch.org (Postfix) with ESMTPid BEB0E36E8B; Fri, 22 
>Sep 2000 08:21:54 -0400 (EDT)
>Received: with LISTAR (v0.129a; list lfs-discuss); Fri, 22 Sep 2000 
>08:21:54 -0400 (EDT)
>Received: from tomts7-srv.bellnexxia.net (tomts7.bellnexxia.net 
>[209.226.175.40])by shadowfax.linuxfromscratch.org (Postfix) with ESMTP id 
>3A5E236E3Bfor <lfs-discuss at linuxfromscratch.org>; Fri, 22 Sep 2000 08:21:54 
>-0400 (EDT)
>Received: from gwaihir.linuxfromscratch.org ([216.209.74.216])          by 
>tomts7-srv.bellnexxia.net          (InterMail vM.4.01.03.00 201-229-121) 
>with ESMTP          id 
><20000922122043.SNMA23574.tomts7-srv.bellnexxia.net at gwaihir.linuxfromscratch.org> 
>          for <lfs-discuss at linuxfromscratch.org>;          Fri, 22 Sep 2000 
>08:20:43 -0400
>Received: from gwaihir (localhost.localdomain [127.0.0.1])by 
>gwaihir.linuxfromscratch.org (8.10.1/8.9.3) with SMTP id e8MCL5Y11314for 
><lfs-discuss at linuxfromscratch.org>; Fri, 22 Sep 2000 08:21:05 -0400
>From lfs-discuss-owner at linuxfromscratch.org Fri Sep 22 05:25:26 2000
>Organization: LFS
>X-Mailer: KMail [version 1.1.94]
>References: <F252IVvLVKi3s1wsXZZ00001bc8 at hotmail.com>
>In-Reply-To: <F252IVvLVKi3s1wsXZZ00001bc8 at hotmail.com>
>Message-Id: <00092208210503.11294 at gwaihir>
>Sender: lfs-discuss-owner at linuxfromscratch.org
>Errors-To: lfs-discuss-owner at linuxfromscratch.org
>X-original-sender: gerard at linuxfromscratch.org
>Precedence: bulk
>
> > I delved into this a bit further and found that the file it is calling,
> > /mnt/usr/src/glibc-build/elf/ld-linux.so.2, links to ld.so in the same
> > directory.  If I run ld.so in that directory without any parameters, I 
>also
> > get "Segmentation fault" so I am assuming that this compiled 
>incorrectly.
>
>Nasty bugger one yes. Ok here's what you can try: Install all packages from
>chapter 5 and skip Glibc. then enter chroot and try to compile chroot from
>within chroot. You will have to copy the libnss* files from the starting
>distro (LFS) by running cp -a /lib/libnss* /mnt/lfs/lib
>
>I don't see how that makes much of a difference, but it never hurts to try.
>
>
>--
>Gerard Beekmans
>www.linuxfromscratch.org
>
>-*- If Linux doesn't have the solution, you have the wrong problem -*-
>
>

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 
http://profiles.msn.com.






More information about the lfs-dev mailing list