After chroot, GCC 2.95.2 won't compile - host type???

Lab Monkey labmonkey at hfx.eastlink.ca
Tue Jan 2 07:10:30 PST 2001


1/2/2001 9:04:00 AM, <jfclinux at fuse.net> wrote:

>Hello,
>
>I've been going through the lfs book step by step trying  to get everything installed.  So far, everything has gone well until I tried to compile GCC 2.95.2 after changing root to 
the lfs (Chapter 6).  The error I get is that it cannot guess my host type.  So, I added --host=i686 to my /configure line.  It looks like it starts to work, and then it bombs saying 
i686-pc-none is not a valid host type (in /usr/src/gcc-build/gcc).  I've tried i386, i586, etc., but I keep getting the same error.  I looked at configure.guess, but I'm pretty new at 
this and really didn't know what to look for.  Any ideas?  I hope I can get it working, because this has already been an awesome learning experience!! I'm not sure if it matters, 
but here are my machine specs:
>
>K7-750MHZ Athlon
>KA7-100 Abit Mobo
>128MB PC133 RAM
>20.5 GB ATA-66 IBM Harddrive
>10X Pioneer DVD
>HP 8100i CD Writer
>Asus V6600 Deluxe Geforce SDR
>SB Live Platinum
>Linksys NIC for DSL Access
>
>Thanks
>John
>
>
>-- 
>Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
>and put unsubscribe in the subject header of the message
>
>

godd morning friend!
i had the exact same problem myself a couple weeks ago. interestingly enough, i have almost the same computer as you. coincidence?

for your host, enter "i686-pc-linux-gnu". i believe that should work. at least, it did for me.

lab monkey



-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list