Kernel Panic on First Time Reboot

John Clisham jfclinux at fuse.net
Fri Jan 5 13:39:54 PST 2001


Gerard,

I just tried rebooting into the LFS, and it does say it mounted root as type 
ext2.  Just after that is when I get the Kernel panic error with the message:

Warning: unable to open initial console
Kernel panic: No init found.  Try passing init= option to kernel?

Any other ideas?  I'm really stuck on this one!

Thanks
John

On Friday 05 January 2001 09:31 am, you wrote:
> On January  5, 2001 07:23 am, jfclinux at fuse.net wrote:
> > I'm at my work pc right now, but I'm betting the init binary is in /sbin
> > since throughout the book, I only had one failed compile, and I fixed
> > that before moving on to anything else.  Also, my inittab was incorrect
> > at first (typos), but I have since fixed it by copying/pasting from the
> > book.  Also, I did create all the device files using the Makedev script.
> >
> > When booting, it starts booting OK.  It loads my SBLive driver, USB, etc.
> > It looks like it fails right when fsck is supposed to start.
>
> Look closely at the output from the kernel. Is the root partition mounted
> at all (if so, it will try to start /sbin/init and you should see a message
> similar to "Sysvinit 2.78 booting"

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list