BASH will not make

Barry barry at hartford.uconn.edu
Wed Jan 17 14:53:38 PST 2001


I have an i686 with 2.4.0 and glibc 2.1.3 ...

I had no problems building bash-2.04...

did you try removing the bash-2.04 source directory and untarring the
bash source archive?

Sometimes compile problems will come when a source tree is not fully
cleared.  I hope that that's the problem.  If not, I suspect that
something more deep-rooted is the problem...

btw, a failed tcl/tk install made it impossible for you to install X
4.0.2????

Something is VERY wrong there.  I had no problem building X without
tcl/tk...




Joseph McPherson wrote:
> 
> I originally installed LFS over Christmas.  The installation took time
> but there were no major errors.  BASH was compiled under Linux kernel
> 2.2.17, XFree86 3.3.5 and Glibc 2.1.1.  BASH configured, made and
> installed with no problems.
> 
> After this experience with LFS I felt confident.  Next I tried to
> install Tcl/Tk 8.0.5 as I had used it in OS/2.  This is when the
> problems started and the long and short of it was that Tk refused to
> install and I lost interest in determining why.  As a by product XFree86
> 4.0.2 would not install.  I, then reformatted the disk and started to
> reinstall LFS.  BASH would not install.  I tried both version 2.03 and
> version 2.04.  I used ./configure with and without the book options.
> When make is executed the following error is generated.
> 
> rm -f shell.o
> gcc  -DPROGRAM='"bash"' -DCONF_HOSTTYPE='"i686"'
> -DCONF_OSTYPE='"linux-gnu"' -DCONF_MACHTYPE='"i686-pc-linux-gnu"'
> -DCONF_VENDOR='"pc"' -DSHELL -DHAVE_CONFIG_H  -D_FILE_OFFSET_BITS=64
> -I.  -I. -I./include -I./lib -I/usr/local/include -g -O2 -c shell.c
> In file included from shell.h:26,
>                  from shell.c:45:
> general.h:190: parse error before `string_to_rlimtype'
> general.h:190: warning: data definition has no type or storage class
> general.h:191: parse error before `int'
> make: *** [shell.o] Error 1
> 
> I have a i686 pc running the Linux kernel 2.4.0.  I am using the GNU C
> Library stable version 2.1.1,  This error is consistent and seems to
> come from the failure to define RLIMTYPE.  I have tried defining
> RLIMTYPE as an "int" but this just creates errors of a different sort
> and does not create an executable program.  It was to easy a fix anyway.
> 
> My request is could someone out there with a i686, Linux 2.4.0 and Glibc
> 2.1.x make BASH and report if they get the same results.  I have
> reported this to GNU.  But no response.  I have read everything I can
> find on static builds of BASH nothing seems relevant.
> 
> Joe
>

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list