glibc 2.2.1 make errors

Thomas T. Veldhouse veldy at veldy.net
Fri Jan 19 11:27:53 PST 2001


Did you create a build directory and build from there?  The INSTALL file
explicity states not to build in the source tree.  That may have not caused
your error, but it is something to look at.

tar xvzf glibc-2.2.1.tar.gz
(cd glibc-2.2.1 && tar xvzf ../glibc-linuxthreads-2.2.1.tar.gz)
mkdir build
cd build
.../glibc-2.2.1/configure --prefix=/usr --enable-addons
make all install

I have had successful builds with make-3.79.1 and gcc-2.95.2.1 against
linux-2.4.0 (and modutils-2.4.0) on an otherwise stock Slackware 7.1 system.

Tom Veldhouse
veldy at veldy.net

----- Original Message -----
From: "Marcus Larsson" <kore at tg.eyeque.org>
To: <lfs-discuss at linuxfromscratch.org>
Sent: Friday, January 19, 2001 1:02 PM
Subject: glibc 2.2.1 make errors


> Hello
> when trying to compile glibc 2.2.1 ....
>
> make  -C dlfcn subdir_lib
> make[1]: Entering directory `/home/kore/glibc-2.2.1/dlfcn'
> ../Makerules:720: warning: overriding commands for target `/lib'
> ../Makerules:718: warning: ignoring old commands for target `/lib'
> ../o-iterator.mk:9: warning: overriding commands for target `/lib'
> ../Makerules:720: warning: ignoring old commands for target `/lib'
> ../o-iterator.mk:9: warning: overriding commands for target `/lib'
> ../o-iterator.mk:9: warning: ignoring old commands for target `/lib'
> ../Makerules:809: warning: overriding commands for target `/lib'
> ../o-iterator.mk:9: warning: ignoring old commands for target `/lib'
> ../Makerules:812: warning: overriding commands for target `/lib'
> ../Makerules:809: warning: ignoring old commands for target `/lib'
> make[1]: Nothing to be done for `subdir_lib'.
> make[1]: Leaving directory `/home/kore/glibc-2.2.1/dlfcn'
> make  -C malloc subdir_lib
> make[1]: Entering directory `/home/kore/glibc-2.2.1/malloc'
> ../Makerules:673: *** multiple target patterns.  Stop.
> make[1]: Leaving directory `/home/kore/glibc-2.2.1/malloc'
> make: *** [malloc/subdir_lib] Error 2
>
>
> i get alot of warning: overriding commands for target `/lib'
> and warning: ignoring old commands for target `/lib'
>
>
> does anyone know what the problem might be
>
> i use gcc2.95.2 and my system has glibc2.1.3
>
> /marcus
>
>
>
> --
> Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
> and put unsubscribe in the subject header of the message
>
>


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list