glibc2.2.1 compile problems

talein at whitestar.soark.net talein at whitestar.soark.net
Sun Jan 21 01:25:07 PST 2001


Hello list :)

been browsing the archives whilst attempting to get this LFS working
on a spare (ex-bsd) partition I have lying around, but haven't been
able to find any possible answers to the problem I've been having
with glibc2.2.1 - am hoping someone else either knows enough about this
or has encountered (and worked through) a similar problem.

Have followed the book (after a few futile attempts at getting my own
system w/o following the book), all the way up to 5.10 - installing
glibc  (and yes, I know it refers you to 2.1.3, iirc, but ... *grins*)

When compiling from my debian partition (using current unstable debian
gcc (which is from gcc CVS), I get this:

<outputting what I do as well as any abnormal output as well>

CFLAGS='-march=k6' ../glib2.2/configure --prefix=usr --enable-add-ons --with-hea
ders=/linux2/usr/include

<appears to work fine, except for warning (also pasting lines above warning):

checking for gcc... gcc
checking version of gcc... 2.95.3, ok
checking for gnumake... no
checking for gmake... no
checking for make... make
checking version of make... 3.79.1, ok
checking for gnumsgfmt... no
checking for gmsgfmt... no
checking for msgfmt... no
checking for makeinfo... makeinfo
checking version of makeinfo... 4.0, ok
checking for gsed... no
checking for sed... sed
checking version of sed... 3.02, ok
configure: warning:
*** An auxiliary program is missing or too old;
*** some features will be disabled.
*** Check the INSTALL file for required versions.

But configure completes successfully, and I get an 'ok' for each "type"
above (except msgfmt), I figure it's ok...

make

<wait a good 30-40 minutes>
make[2]: Leaving directory `/linux2/usr/src/packages/glibc-2.2/hesiod'
make  -C sunrpc others
make[2]: Entering directory `/linux2/usr/src/packages/glibc-2.2/sunrpc'
<handful of successful gcc lines>
/linux2/usr/src/packages/glibc-build/elf/ld-linux.so.2 --library-path /linux2/usr/src/packages/glibc-build:/linux2/usr/src/packages/glibc-build/math:/linux2/usr/src/packages/glibc-build/elf:/linux2/usr/src/packages/glibc-build/dlfcn:/linux2/usr/src/packages/glibc-build/nss:/linux2/usr/src/packages/glibc-build/nis:/linux2/usr/src/packages/glibc-build/rt:/linux2/usr/src/packages/glibc-build/resolv:/linux2/usr/src/packages/glibc-build/crypt:/linux2/usr/src/packages/glibc-build/linuxthreads /linux2/usr/src/p
ckages/glibc-build/sunrpc/rpcgen -Y `gcc -print-file-name=cpp | sed 's|/cpp$||'` -c rpcsvc/bootparam_prot.x -o /linux2/usr/src/packages/glibc-build/sunrpc/xbootparam_prot.T
BUG IN DYNAMIC LINKER ld.so: dl-load.c: 614: _dl_init_paths: Assertion `pelem->dirname[0] == '/'' failed!
make[2]: *** [/linux2/usr/src/packages/glibc-build/sunrpc/xbootparam_prot.stmp] Error 127
make[2]: Leaving directory `/linux2/usr/src/packages/glibc-2.2/sunrpc'
make[1]: *** [sunrpc/others] Error 2
make[1]: Leaving directory `/linux2/usr/src/packages/glibc-2.2'
make: *** [all] Error 2

.... ok - very strange - last time I tried this, it segfaulted rather
than giving this error.

At first, I assumed it was a gcc issue (as cvs builds are not particularly
known for stability) so I followed the instructions to wait until chapter
6 to compile glibc -- compiled texinfo and textutils statically, chroot'd
and started to configure/compile glibc from my LFS gcc 2.95.2.  That,
however, errors MUCH sooner, with errors similar to those shown in a 
previous post:
http://archive.linuxfromscratch.org/mail-archives/lfsdiscuss/10546.html

If anyone has any ideas what's wrong, or (more importantly) how to fix
this, it would be greatly appreciated.

Thanks,
 - Brian E. Ermovick

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list