Gettext

Gerard Beekmans gerard at linuxfromscratch.org
Wed Jan 31 12:15:16 PST 2001


On January 31, 2001 06:22 am, you wrote:
> Last night I modified all my LFS install scripts to comply with the
> latest CVS version of the book, and everything went smoothly until
> gettext.  make fails on msgfmt because it has no rule to make
> libnlsut.a.  I did a search on google for "libnlsut.a" (and
> search.linuxfromscratch.org for "msgmfmt" since "libnlsut.a" didn't
> return anything, but that yielded nothing but people with glibc-2.2.1
> problems and package content descriptions from the book for gettext),
> but all I got were BSD patches for gettext and some package logs.  I
> know this is the _CVS_ version of the book and therefore not intended to
> be looked at as a stable release, but submitting possible bugs like this
> can only make it better.  I'll be looking into this problem further this
> evening, but any help I can get from you guys is greatly appreciated.
> Thanks!

No, CVS bugs are very welcome and needed. Else it'll never leave CVS :)

Frank Langtind also had a problem with gettext. From the output Frank gave me 
he did cd src && make. Also --prefix=$LFS/usr was used, which isn't needed 
here since we don't do a full install.

Hmm. i just did a regular ./configure && make LDFLAGS=-static and it worked 
fine. The reason it failed on me before was that I ran from a Glibc-2.1.3 
system, from Glibc-2.2.1 it doesn't cause problems.

I'll have to get back in my old LFS system and refine these installation 
instructions. I'll get back to you guys with proper gettext instructions.

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list