glibc configure hangs

Sanjuro E sanjuro_e at yahoo.com
Tue Jul 3 01:21:28 PDT 2001


I think I have found the problem.

I looked at the 'configure' script and manually tried
executing the command in the section where it hangs.

It first evaluates some string I don't understand but
I copied it and it returned false. After that it
creates this program:

#include <stddef.h>
FOOBAR __SIZE_TYPE__ FOOBAR

And runs it through 'cpp'.

When I use the cpp of my base system everything works
fine cpp exits with some error about unsigned type
which the configure script checks for. But when I do
this in chroot with the static cpp it generates the
same error but does NOT exit.

So I guess the problem is with cpp, but how do I fix
this?

Sanjuro


--- Sanjuro Europa <sanjuro_e at yahoo.com> wrote:
> This morning I finished my last exam so I decided to
> build a new LFS 
> 3.0-pre4 system.
> 
> My base system is a LFS 2.4 system with kernel
> 2.4.2. I compiled all static 
> programs entered chroot environment and started
> compiling glibc. When 
> running 'configure' I get the output below and then
> the program just stops. 
> I waited for 2 minutes and more, but nothing else
> happened.
> 
> I think I did something wrong along the way but
> what?
> 
> Sanjuro



__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
http://personal.mail.yahoo.com/
-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list