gcc installed but bash says it doesn't exist

Adrian Ho aho-lfs-discuss at 03s.net
Thu Jul 5 06:36:20 PDT 2001


On Thu, Jul 05, 2001 at 02:23:35PM +0100, Ian Chilton wrote:
> > However, when I try to run gcc, even for gcc --version,
> > I get a bash error (bash: /usr/bin/gcc: no such file or directory).
> > Gcc does show up in the /usr/bin/gcc directory and I get
> > the same error if I call gcc from /home/.
> 
> Are you sure that your paths are right?

Since the bash error message specifically said "/usr/bin/gcc", I doubt
PATH is the problem.  It's probably an error during gcc compilation
or installation, or both -- the gcc-lib path that's compiled into
/usr/bin/gcc may be wrong, or he installed some gcc components in the
wrong dir.

Greg, check the commands you used to build static gcc.  Make sure prefix
is /usr during "./configure", but $LFS/usr during "make install" (adjust
the other install dirs accordingly).  I haven't tried building gcc 3.0,
so I won't go into specifics, but I hope you get the general idea.

- Adrian
-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list