gcc installed but bash says it doesn't exist

Nicholas Dille webmaster at rakshas.de
Thu Jul 5 06:48:02 PDT 2001


> I just finished the first part of the system install,
> installing all the statically linked programs.  I made a
> password/group file, copied over the nss libs (from
> glibc2.1), mounted the LFS proc, and changed the root.  The
> next step is compiling glibc.  However, when I try to run
> gcc, even for gcc --version, I get a bash error (bash:
> /usr/bin/gcc: no such file or directory).  Gcc does show up
> in the /usr/bin/gcc directory and I get the same error if I
> call gcc from /home/.  I had the same problem with the bzip2
> utilities, but after reinstalling them they worked properly.
> I tried reinstalling gcc without success.  This is gcc 3.0,
> my previous glibc is 2.1, both new and old partitions are
> reiserfs 3.5 formatted, the new bash is 2.05 and the old is
> 2.04, previous gcc is 2.95.2, previous mak e is 3.79.  I have
> run out of ideas, please help.

i had similar problems when i used optimization for gcc in chapter 5.
you might want to lower optimization.

in my case i was using "-O3 -march=i586" but "-O2 -march=i586" does
the trick for gcc.

hth,
nic.


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list