(no subject)

Guillermo Pereyra Irujo gpirujo at mdq.com
Sun Jul 8 11:07:12 PDT 2001


> Ok, I have mentioned this before, but until now, I didn't have to
> opportunity to recreate this phenomena.
>
> When I download a binary, "squake" for example, chmod 755, then try to
> execute "./squake" I get the error "sh: ./squake: No such file or
> directory"
>
> This happens only with executables downloaded in binary form, when I
> compile the executable, it works fine.
>
> I have tried FTP, HTTP and good old floppy with the same results.
>
> I have another Linux box, I try it, it works fine.
>
> This is not just squake, this is all downloaded binaries and even
> downloaded scripts.  (i can dump scripts via Telnet, or i wouldn't
> have gotten this far)
>
> As a sanity check, AND THIS IS THE KICKER, I extracted it in my old
> host OS (suse 6.3) chmod 755, ran it, it spit out an error saying i
> didn't have the pak files (which means it worked) THEN rebooted into
> LFS and it STILL didn't work.
>
> What am I doing wrong?

I got this error when trying to execute SCO binaries in Linux without
having loaded the ibcs modules which allow these "foreign-type"
executions. They were not corrupted, just incompatible.

Perhaps you are downloading something that is in a different format (those
a.out and elf things that I don't understand very much) and you need
something else in the kernel.

-- 
Guillermo Pereyra Irujo
Mar del Plata, Argentina


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list