Cannot execut rcS

Lucas Nelson lucas at access.com.au
Mon Jul 9 00:41:47 PDT 2001


On Mon, Jul 09, 2001 at 09:34:14AM +0200, Hartmut Brüning wrote:
> Guten Tag from Germany
> 
> I just compiled my LFS3.0pre3. But I am not able to boot it.
> When I boot my LFS the following messages appear:
> "NIT cannot execute "/etc/init.d/rcS
> INIT Entring runlevel: 3
> INIT cannot execute /etc/init.d/rc
> 
> I booted my Mandrake again and checked, wheatcher the rights
> on $LFS/etc/init.d/rcS are correct. They are on 754. ls -F shows
> a star after the filename, so it is executable. Next I tried
> to execute $LFS/etc/init.d/rcS in my Mandrake. For my
> Surprise Linux does'nt want to run it although it is able to
> execute the boot script from my Mandrake Linux manually which
> has the same rights and type.
> 
> What should I do? I know that a script must be marked as
> executable. But in all Howtos, Guides and FAQs I read I
> could not find the command for making this. And ls shows
> it is always executable. But why can't I run this file?
> 
> I hope anyone has an idea

Double check the very first line of the rcS and rc files, it should be:

#!/bin/sh

no spaces before the #
no spaces after the sh
no blank line before that line.

Try executing the script from your Mandrake installation, in the chroot'ed
environment: /etc/init.d/rc

Make sure that $LFS/bin/sh exists and points to a valid bash binary.

Lucas.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 232 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-dev/attachments/20010709/f0123002/attachment.sig>


More information about the lfs-dev mailing list