Cannot execut rcS

Sebastian Edman sebastian.edman at imsys.se
Mon Jul 9 00:40:29 PDT 2001


Problem with CR+LF
did you notice the initial '"' it is the last charachter printed on that 
line but since the files name actually is rcS<CR> it is printed at the 
beginning of the line. The problem is that you have a trailing <CR> at the 
filename in inittab probably caused by cut'n paste in diffrent OS...

I had the exact same problem ;)

/sebastian

At 09:34 2001-07-09, you wrote:
>Guten Tag from Germany
>
>I just compiled my LFS3.0pre3. But I am not able to boot it.
>When I boot my LFS the following messages appear:
>"NIT cannot execute "/etc/init.d/rcS
>INIT Entring runlevel: 3
>INIT cannot execute /etc/init.d/rc
>
>I booted my Mandrake again and checked, wheatcher the rights
>on $LFS/etc/init.d/rcS are correct. They are on 754. ls -F shows
>a star after the filename, so it is executable. Next I tried
>to execute $LFS/etc/init.d/rcS in my Mandrake. For my
>Surprise Linux does'nt want to run it although it is able to
>execute the boot script from my Mandrake Linux manually which
>has the same rights and type.
>
>What should I do? I know that a script must be marked as
>executable. But in all Howtos, Guides and FAQs I read I
>could not find the command for making this. And ls shows
>it is always executable. But why can't I run this file?
>
>I hope anyone has an idea
>
>Hartmut
>--
>Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
>and put unsubscribe in the subject header of the message

--
Sebastian Edman <sebastian.edman at imsys.se>
Imsys AB <www.imsys.se>
Johanneslundsv. 3
194 61 Upplands Väsby

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list