gcc installed but bash says it doesn't exist

David Anselmi anselmi at intradenver.net
Tue Jul 10 09:47:44 PDT 2001


Hi all,

I'm late thanking everyone for LFS - got my system working a few weeks ago but have been playing with kernel modules and NIC drivers so I've been distracted.  But that's another post.

I had a problem similar to this with a "works with linux" modem.  I had a similar error message trying to use the program the vendor supplied to set up the modem (fortunately they provided directions for using setserial to do it, too).

What I learned was that it helps a lot if I take a few minutes to read the error message and understand it.  I originally made the mistake Greg did.  Let's look:

bash: /usr/bin/gcc: no such file or directory

What is this really trying to say?  We'll, you told bash to run a program (that's the bash: part).  The program had a problem (the /usr/bin/gcc: part).  The problem was "no such file or directory".  You see, bash is not complaining that it can't find /usr/bin/gcc.  gcc is complaining that it can't find a file it wants (thanks to the authors for telling us which one - NOT).  In my case, running strings on the program that complained showed it looking for things like libc5, which told me not to bother with it since I don't have those.  So as previously posted, Greg's gcc probably isn't statically linked.  That's pretty obvious from the error message, if you know how to read it.

Dave

yourfriendgregd at netscape.net wrote:

> I just finished the first part of the system install, installing all the statically linked programs.  I made a password/group file, copied over the nss libs (from glibc2.1), mounted the LFS proc, and changed the root.  The next step is compiling glibc.  However, when I try to run gcc, even for gcc --version, I get a bash error (bash: /usr/bin/gcc: no such file or directory).  Gcc does show up in the /usr/bin/gcc directory and I get the same error if I call gcc from /home/.  I had the same problem with the bzip2 utilities, but after reinstalling them they worked properly.  I tried reinstalling gcc without success.  This is gcc 3.0, my previous glibc is 2.1, both new and old partitions are reiserfs 3.5 formatted, the new bash is 2.05 and the old is 2.04, previous gcc is 2.95.2, previous make is 3.79.  I have run out of ideas, please help.
>
> Greg



-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list