Problems getting the eth0 interface up

Stian Johnsen stian.j at
Fri Jul 13 04:55:54 PDT 2001

When I try to boot up my LFS system the ethernet won't work
I get this error message, and the system freezes.

Error message:

INIT: Entering runlevel: 3
Starting System log deamon...                                                                                [ OK ]
Starting Kernel log daemon...                                                                                 [ OK ]
Bringing up the eth0 interface... eth0: setting 100mbps halg duplex based on auto
- negotiated partner ability ffff                                                                                 [ OK ]

divide error: 0000
CPU:       0
EIP:         00010:[<c0105ac>]
Eflags: 00000246
eax: 00000000 ebx: 00105180 ecx: c028a000 edx. c028a000
esi: c028a000 edi: c0105180 ebp: 00082000 esp: c028bfdc
ds:0018 es:0018 ss:0018

Process swapper   (pid:0 stackpage = c028b000)
Stack c0105212 00006000 c028a000 c0105000 c028c8b7 00000000 000a0600 c02c4720 c01001cf

Call trace: [<c01052127>] [<c01050007>]

Code: c3 8d 76 00 fb c3 89 f6 fb ba 00 e0 ff ff 21 e2 b8 ff ff ff

Kernel panic: Attempted to kill the idle task:
In idle task not syncing

And then the machine freezes.

I tried to remove the ethnet boot script, and booted the machine again.
It boots as its suposed to do (Without the ethernet card of course) 
Then I tried "ifconfig eth0" and i get the same error message.

The host system is Red hat 6.2: Kernel 2.2.14-5.0.
The LFS system is running kernel  2.4.6.

The ethernet card works on the host system.

Unsubscribe: send email to lfs-discuss-request at
and put unsubscribe in the subject header of the message

More information about the lfs-dev mailing list