gcc compilation problems

Bealers mail at bealers.com
Tue Jul 17 10:29:33 PDT 2001


Hi there, I still can't get gcc compiled. I'm running RH7.1 which uses gcc
2.9.6, and it barfed when I tried to compile yesterday

Today I 'upgraded' gcc and cpp to 2.9.3 using rpm's from rpmfind.net

I now get this error when I run:
make -e LDFLAGS=-static bootstrap

stage1/xgcc -Bstage1/ -B/mnt/lfs/usr/i586-pc-linux-gnu/bin/ -c  -DIN_GCC    
 -O2 -g -O2  -DHAVE_CONFIG_H    -I. -I../../gcc-2.95.2.1/gcc -I../../gcc-2.9
5.2.1/gcc/config -I../../gcc-2.95.2.1/gcc/../include
../../gcc-2.95.2.1/gcc/c-pragma.c
xgcc: Internal compiler error: program cpp got fatal signal 11
make[2]: *** [c-pragma.o] Error 1
make[2]: Leaving directory `/mnt/lfs/usr/src/gcc-build/gcc'
make[1]: *** [bootstrap] Error 2
make[1]: Leaving directory `/mnt/lfs/usr/src/gcc-build/gcc'
make: *** [bootstrap] Error 2

Is it possible that my gcc upgrade messed up somehow? I did try compiling
2.9.3 first, before using the RPM's but that barfed also.

Any help would be greatly appreciated, I downloaded the lfsdiscuss archive,
but I see no-one else having the smae problems as me

TIA
--
Darren Beale
mail at bealers.com

Who wants the rewind?

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list