DRI

Igor Zlatkovic izlatkovic at daenet.de
Thu Jul 19 06:13:18 PDT 2001


Hello there.

This is about DRI in XFree86 4.1. Here is what glxinfo says when I run
it as root:

  [astaroth:~]# glxinfo
  name of display: :0.0
  display: :0  screen: 0
  direct rendering: Yes

And here is what it says when I run it without root privileges:

  [astaroth:~]$ glxinfo
  name of display: :0.0
  display: :0  screen: 0
  libGL error: failed to open DRM: Operation not permitted
  libGL error: reverting to (slow) indirect rendering
  direct rendering: No

Just what is it trying to open? I have played with the permissions in
/dev/dri/card0 and even in /proc/dri, to no avail.

I have searched the web for this problem and found one site, in danish,
which describes it. Given my knowledge in danish, I felt somewhat
helpless ;-) However, I was able to decipher a suggestion to put the
following in /etc/X11/XF86Config:

  Section "DRI"
     Group 4000
     Mode 0666
  EndSection

Since I have few hours of work ahead of me before I am able to go home
and see if this ticks, I thought perhaps someone on this list has an
opinion?

Thanks
Igor

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list