bash still won't recognize gcc...

yourfriendgregd at netscape.net yourfriendgregd at netscape.net
Thu Jul 26 16:40:26 PDT 2001


...and that is not good.  I started a thread about this some weeks ago, but due to some technical difficulties on the behalf of my computer, was unable to try solutions.  Well, I tried them, and also tried compiling bash (2.05) without the "--with-cursers" option.  To recap, when I try to execute gcc in the chroot environment, bash complains that the executable (gcc) doesn't exist.  However, using ls shows that gcc exists, and I can auto-complete "gcc" by using the tab key.  Using ./gcc when in /usr/bin yields the same results.  Compiled gcc 2.95.2.1 statically with glibc 2.1 and gcc 2.95.2.  Here is the output I get in the chroot environment:

I have no name!:~#gcc
bash: /usr/bin/gcc: No such file or directory
I have no name!:~#cd /usr/bin/
I have no name!:/usr/bin#ls
addr2line  egrep   hostid                 objcopy   size      uniq
ar         env     i686-pc-linux-gnu-gcc  objdump   sleep     unprotoize
as         expand  id                     od        sort      uptime
basename   expr    info                   paste     split     users
c++        factor  install                patch     strings   wc
c++filt    fgrep   install-info           pathchk   strip     who
cc         fmt     join                   pinky     sum       whoami
chroot     fold    ld                     pr        tac       yes
cksum      g++     logname                printenv  tail      zcat
cmp        gasp    make                   printf    tee       zcmp
comm       gcc     makeinfo               protoize  test      zdiff
cpp        gcov    mawk                   ptx       texi2dvi  zforce
csplit     gprof   md5sum                 ranlib    texindex  zgrep
cut        grep    nice                   readelf   tr        zmore
diff       groups  nl                     rmt       tsort     znew
diff3      gzexe   nm                     sdiff     tty
dirname    head    nohup                  seq       unexpand
I have no name!:/usr/bin#gcc
bash: /usr/bin/gcc: No such file or directory

Thanks for any advice,
Greg



__________________________________________________________________
Your favorite stores, helpful shopping tools and great gift ideas. Experience the convenience of buying online with Shop at Netscape! http://shopnow.netscape.com/

Get your own FREE, personal Netscape Mail account today at http://webmail.netscape.com/

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list