tmp directories.

Paul Campbell paul at cmm.uklinux.net
Sat Jul 28 21:02:58 PDT 2001


Hi,

I have had my LFS system up and running now for a few weeks and all is going 
well, but....

I have a few problems, regarding both KDE and Xmms, that can only it seems be 
resolved by deleting the contents of the /tmp directory.

I have compiled the LFS3.0-pre4 system as per the book, and followed the LFS 
hints for X11, KDE and then compiled libmpg132 and xmms.  It runs absoloutely 
fine, better than I've ever seen.  Then for no reason it crashes on attempt 
of playing an mp3, after this crash mpg123 can not play either.

At first I thought this was due to probs with ext2fs and the X-crash reset 
syndrome I have (I've now gone reiserfs), so I re-compiled both libmpg and 
xmms and it worked.  The second time I only recompiled xmms and it worked.  
The third time I only deleted the /tmp contents and it worked, after a 
fashion.

KDE has had some probs booting after a crash, loading what appears to be 
1000s of megs into the swap file and not doing much else.  Again deleting the 
contents of /tmp solves the probs.

Should the contents of /tmp not be deleted as part of rcS.d or rc[06].d?  Or 
do we not need a tmpwatcher cron or something?  It's just that stuff seems to 
hang around in /tmp for quite a while and cause problems.

-- 
paul at cmm.uklinux.net
http://www.cmm.uklinux.net
-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list