The LFS system and ssh

Ainsley Pereira marble at linuxfromscratch.org
Sun Jul 29 04:42:56 PDT 2001


In message <01072913384200.00601 at back>
          Chris Lingard <chris at stockwith.uklinux.net> wittered:

> Have built the LFS onto my two machines; got the tar ball from a CD given
> away with a magazine.  Just followed the book and everything was OK.  I run 
> KDE on this machine, and my other machine is the fire wall.

Cool:) Welcome to control-freak central;)

> Have just two problems.  Have installed ssh, enabled the port 22 stuff in 
> /etc/services and through the fire wall.  I need to ssh into the other 
> machine to run the pppd script.
> 
> ssh takes about 30 seconds to connect,  surely this is wrong?

Sounds like it's trying to resolve your hostname. Do you have the client's ip
address & name in the server's /etc/hosts file?

(eg. my firewall's hosts file looks like:

127.0.0.1       localhost.localdomain   localhost
192.168.1.1     cordelia.sunnydale      cordelia
192.168.1.10    buffy.sunnydale         buffy
192.168.1.12    willow.sunnydale        willow
192.168.1.14    faith.sunnydale         faith

where the firewall is 'cordelia', and I can ssh into it without problems.)

> I run qmail and fetchmail, and read by mail using kmail;  When I run
> fetchmail I get:
> 
> SMTP connect to localhost failed

Sounds like qmail isn't actually running. Did you add a qmail init script and
a link from your normal runlevel to it? (/etc/init.d/qmail and
/etc/rc3.d/S100qmail or similar)
You know you don't actually need qmail/fetchmail to read/send mail with
kmail, right? I don't use qmail myself, but others here do.

> I can put up with the first, and have hacked round the second,  but would 
> like to check what I have done wrong.  Appologies if this is a regular fault, 
>  but I have only just got LFS, and joined the mailing list.

Check out the webpage for list archives/FAQ etc.

-- 
 ----------------------------------------------------------
  / Ainsley 'Marble' Pereira / http://www.snowplains.org /
 / Don't drink and drive.
-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the lfs-dev mailing list