Make problems

Rayner Lucas rayner at calris.fsnet.co.uk
Mon Mar 5 15:40:04 PST 2001


From: Gerard Beekmans <gerard at linuxfromscratch.org>

>> I have found getloadavg.c in /usr/src/glibc-2.2.1/. Do I need to
recompile
>> all of glibc? Any ideas why it failed to be installed the first time?
>
>No ideas, never seen it before. You can try to reinstall Glibc (inside
>chroot) and see if that solves anything.


Well, I reinstalled glibc (just what I was dreading - the build chews
unbelievable amounts of disk space). Worked fine, modulo the crash during
compilation and the subsequent reboot-n-fsck...

libutil was installed in /lib, as it should be, and I was finally able to
install make afterwards (after deleting config.cache so configure could find
the newly-installed libraries).

So, problem solved (though I'm still not sure why it didn't work the first
time).

Many thanks to you and all who responded with help.

    Rayner


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list