sh-utils-2.0 install

Lab Monkey labmonkey at ns.sympatico.ca
Tue Mar 6 10:24:45 PST 2001


3/6/2001 3:53:51 AM, Gerard Beekmans <gerard at linuxfromscratch.org> wrote:

>On March  5, 2001 04:45 pm, Lab Monkey wrote:
>> howdy.
>> i am unable to get shellutils (book 2.4.4, ch 05) to install.
>> it stops on the command "make LDFLAGS=-static &&", with the following error
>> message:
>>
>> cd . && aclocal -I m4
>> aclocal: m4/gettext.m4: 13: duplicated macro `AM_WITH_NLS'
>> aclocal: m4/gettext.m4: 199: duplicated macro `AM_GNU_GETTEXT'
>> aclocal: m4/lcmessage.m4: 13: duplicated macro `AM_LC_MESSAGES'
>> aclocal: m4/progtest.m4: 13: duplicated macro `AM_PATH_PROG_WITH_TEST'
>> make: *** [aclocal.m4] Error 1
>>
>>
>> any help would be greatly appreciated.
>
>These problems have been fixed before. Have you tried searching the 
>mailinglist archives?
>

i have tried searching the archives, yes. i was unable to find the solution. if the solution is in the archives, i apologize for wasting more of your time.
however, except for one person (Thu Jan 04 2001 - 00:02:28 EST) who never got a response, all the other problems with sh-utils that i found were for different error 
messages. they were were given the solution of doing a dynamic link, rather than a static one. i tried that as well, and got the same error messages as before.
as well, i notice that all the other messages were using the command, "make  -e LDFLAGS=-static". the 2.4.4 book does not use the -e flag. is this intentional?


-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list