I've tried and tried "koffice"

Marc Heerdink marc_heerdink at softhome.net
Fri Mar 23 16:24:01 PST 2001


michael nazaroff wrote on Sat, 24 Mar 2001 00:02:00 -0000:
> Ok, this should be really easy to compile and I'm thought all the 
> dependencies where met cause every other package compiled except this on in 
> kde.  I have no clue what the problems is so figured I would throw this out 
> there and see if there is some kinda answers:
<snip>
> /usr/src/kde/koffice/kivio/kiviopart/.libs/libkiviopart.so: undefined 
> reference
> to `pthread_create'
> /usr/src/kde/koffice/kivio/kiviopart/.libs/libkiviopart.so: undefined 
> reference
> to `pthread_detach'

"pthread" is the posix threading package. This library is included with
glibc-linuxthreads. Apperantly (from the output of the make program), you're not
linking to the pthread library, although the program needs it. Try to add
-lpthread to the linker flags.

-- 
There is no programming language, no matter how structured,
that will prevent programmers from writing bad programs.
- L. Flon

Marc Heerdink
marc_heerdink at softhome.net
http://www.koelkast.net/

-- 
Unsubscribe: send email to lfs-discuss-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the lfs-dev mailing list