RH 6.0 mv breakdown on hard-linked files.

Bill Maltby LFS Related lfsbill at wlmcs.com
Wed May 8 20:31:56 PDT 2002


Hi folks,

Just in case anyone else comes on doing LFS from *old* distro,
I thought I would pass this on. RH 6.0, 2.2.5-15. Version info:

  GNU C Library stable release version 2.1.1
  Compiled by GNU CC version egcs-2.91.66 19990314/Linux (egcs-1.1.2
    release).
  Compiled on a Linux 2.2.5-8 system on 1999-04-16.

Running LFS 3.3 bzip2 install for chapter5, the following command
fails with "mv: /mnt/hdc2/bin/bzmore: No such file or directory".

  mv -vf bzcat bunzip2 bzip2 bzip2recover bzless bzmore /mnt/hdc2/bin.

An ls -li command was inserted and revealed that bzless and bzmore
were hard-linked together.

Breaking the command into two, as follows, worked.

  mv bzcat bunzip2 bzip2 bzip2recover bzless /mnt/hdc2/bin
  mv bzmore /mnt/hdc2/bin

I suspect that just moving bzless away from bzmore may have also
worked. I will try that next time I install on my RH 6.0

Bill Maltby
billm at wlmcs.com

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list