RH 6.0 mv breakdown on hard-linked files.

Bill Maltby LFS Related lfsbill at wlmcs.com
Thu May 9 05:45:02 PDT 2002


On Thu, 9 May 2002, Christophe Devine wrote:

> Bill Maltby LFS Related wrote:
> 
> > Hi folks,
> 
> Hi Bill,
> 
> > Just in case anyone else comes on doing LFS from *old* distro,
> > <snip>

> I've tried to install chapter 5 from a RedHat 6.0, and did encounter the
> same problem; I get the following error message:
> 
> # mv /mnt/lfs/usr/bin/{bzcat,bunzip2,bzip2,bzip2recover,bzless,bzmore}
> \ /mnt/lfs/bin
> mv: /mnt/lfs/bin/bzmore: No such file or directory
> 
> >   mv -vf bzcat bunzip2 bzip2 bzip2recover bzless bzmore /mnt/hdc2/bin.
> > 
> > An ls -li command was inserted and revealed that bzless and bzmore
> > were hard-linked together.
> > 
> > Breaking the command into two, as follows, worked.
> > <snip>

> One possible solution would be to replace the hardlink with a symlink
> before moving the files:
> 
> # ln -sf bzmore $LFS/usr/bin/bzless
> # mv /mnt/lfs/usr/bin/{bzcat,bunzip2,bzip2,bzip2recover,bzless,bzmore} /mnt/lfs/bin
> # ls -l $LFS/bin/bzless
> lrwxrwxrwx   1 root     root            6 May  9 10:38 /mnt/lfs/bin/bzless -> bzmore

Yes. But I'm doing a little "generalized" automation stuff designed
to work *with* LFS and BLFS as closely as possible. So I *try* to
keep the commands executed as close as possible to what's in the book.
With that in mind, making two moves seemed "closer" to the book.

My hope is that anyone else using the package will apply command
changes from later versions of the book and be able to see in my
scripts the same (almost) they see in the book. But with up-front
local variables collection and some additional security against
system destruction.

Bill Maltby
billm at wlmcs.com

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list