ncurses patch for gcc-3.1

Gerard Beekmans gerard at linuxfromscratch.org
Sun May 26 17:06:18 PDT 2002


I read some emails about people not needing a ncurses patch to get the
Ncurses package to compile properly with GCC-3.1

Are you guys doing anything special? I just tried it and ncurses fails as
execpted like this:

../c++/cursesw.cc: In member function `int NCursesWindow::scanw(const
char*, 
   ...)':
../c++/cursesw.cc:55: no matching function for call to `std::strstreambuf::
   vscan(const char*&, char*&)'
../c++/cursesw.cc: In member function `int NCursesWindow::scanw(int, int,
const 
   char*, ...)':
../c++/cursesw.cc:77: no matching function for call to `std::strstreambuf::
   vscan(const char*&, char*&)'
make[1]: *** [../obj_s/cursesw.o] Error 1

Now, there are these patches that a bunch of people are using to upgrade
ncurses to a more current development snapshot. That's not exactly what I
want to do for the book - I want to keep ncurses as version 5.2 and only
apply a patch that will fix this C++ problem, nothing more and nothing
less.

I remember a while ago somebody posting a patch for ncurses that'll make it
compile with gcc-3.x without applying a development snapshot upgrade patch.

I can't find it anymore so I'm hoping somebody else has it handy somewhere?
I will keep looking for it, but it will take a while. I don't even know
anymore if it was posted to this list or one of the other lists.

-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list