Perl doesn't configure properly, help?????

Luke A. Guest laguest at nospam.abyss2.demon.co.uk
Thu Oct 10 13:40:41 PDT 2002


Hi,

I've been trying to configure perl, but it doesn't do it correctly. It can 
configure fine under Redhat, but not under LFS.

This is not the first version it does it on and I can't get past it this 
time.

After "./configure.gnu --prefix && make && make install" I get this:

        makefile:856: *** missing separator.  Stop.

Ok, delete the "0" on that line - why it's there, I don't know! - and then I 
get:

        rm -rf ../../lib/auto/DynaLoader/DynaLoader.a
        /usr/bin/ar cr ../../lib/auto/DynaLoader/DynaLoader.a DynaLoader.o && :
        ../../lib/auto/DynaLoader/DynaLoader.a
        chmod 755 ../../lib/auto/DynaLoader/DynaLoader.a
        make[1]: Leaving directory `/usr/src/perl-5.8.0/ext/DynaLoader'
        cc -o perl  -L/usr/local/lib -rdynamic perlmain.o       
        lib/auto/DynaLoader/DynaLoader.a  libperl.a `cat ext.libs` -lnsl -ldl -lm 
        -lc -lcrypt -lutil
        cd x2p;  make s2p
        make[1]: Entering directory `/usr/src/perl-5.8.0/x2p'
        makefile:156: *** target pattern contains no `%'.  Stop.
        make[1]: Leaving directory `/usr/src/perl-5.8.0/x2p'
        make: *** [x2p/s2p] Error 2

Did I do something royally wrong in some other part of the installation 
process? I'm asking here, because I'm not getting anywhere on the support 
list.

Thanks in advance,
Luke.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list