Perl doesn't configure properly, help?????

Luke A. Guest laguest at nospam.abyss2.demon.co.uk
Sat Oct 12 06:39:38 PDT 2002


Damian Wojslaw wrote:

> 'lo. I'll answer, since I've just recently solved my own perl
> compilation problem. The lone mad 0 was, in my case, the result of
> improperly created /dev/random. Check if your /dev/random
> looks like this:
> crw-rw-rw- 1 root root  1, 8 Oct 6 13:06 /dev/random
> In my case it was malformed. I had two file /dev/random and
> /dev/random. None of them was a proper /dev/random node. I have deleted
> both and recreated it with mknode c /dev/random 1 8. It not only solved
> problem with this 0, but also solved problem when perl compilation stopped
> somwhere in x2p.

This didn't actually work, so I went back and did the MAKEDEVICE step - I'll 
delete the entries in /dev later, after I've built the kernel.

Thanks for the hint though.

Luke.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list