nitpick about ncurses installation

Matthias Benkmann matthias at winterdrache.de
Mon Oct 14 01:17:48 PDT 2002


In section "Installing Ncurses-5.2" the patch is explained as follows

"This patch fixes a compile problem with GCC-3.2 because Ncurses uses
constructions that are no longer valid in the new C++ standard."

As a C++ programmer I have to pick some nits here. So far there is only
one C++ standard and it's the first. So "no longer valid in the new C++
standard" is not correct. These constructions were never valid in any C++
standard. The explanation should be changed to

"Ncurses uses constructions that are not valid in ANSI C++ and don't
compile with recent GCC versions that conform to the standard."

MSB

-- 
Depression is merely anger without enthusiasm.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list