Issues I ran in to building the latest CVS (For those who care)

Tushar Teredesai tush at yahoo.com
Sun Sep 8 21:17:45 PDT 2002


Steven Stimpson wrote:

>I had it setup right as this: LFS=/mnt/lfs and yes hdb1 was mounted under
> /mnt/lfs and all cases were correct.I was copying and pasting directly from 
>the web page. When I redid it using /mnt/lfs/static as the prefix it worked. 
>
Did u export $LFS?

>When I went to compile binutils in chapter five user LFS did not have 
>permission to create the binutils-build directory.
>
Did you do the "*chown -R lfs $LFS/static" step in Ch. 5 
<*http://www.linuxfromscratch.org/view/cvs/chapter05/installasuser.html>?

> I made a list of all packages installed in chapter five because I do not
>delete the old sources when i am done with them. Instead when a package 
>needs to be re-installed in chapter 6 I simply check the list and if it was 
>already installed in chapter five I do a make distclean on it instead of 
>unpacking everything again. As each package was re-intalled i crossed it 
>off the list.
>
Actually, it is better to remove the sources and untar a fresh source. 
Doing a static build with the same source tree (even after a make 
distclean) has created few problems.

> When chapter 6 was done i still had Findutils gawk sed and sh-utils as not 
>having been re-installed in chapter 6.
>
They are installed in Chapter 6.

-- 
Tushar Teredesai
LFS ID: 1377
http://www.geocities.com/tush/lfs/

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list