GCC-2.95.3-2 from LFS 3.3 flunks the regression test in a big way

Steve Bougerolle steveb at creek-and-cowley.com
Mon Sep 16 18:19:45 PDT 2002


On Mon, 2002-09-16 at 21:30, Greg Schafer wrote:

> Colour me confused! I was trying to figure out what the actual problem
> was. Even now, I still don't get the gist of what you were doing..

Ok, the original problem was that I couldn't compile Qt.  It keeps
bombing on some C++ syntax error in qapplication.cpp.  I've made
absolutely no progress on that still, but that's not a matter for this
list.

While working my way through an endless list of possible remedies for
that I got all the way down to "Check GCC".  This is a new system and I
hadn't done that; as you yourself said a while back, checking GCC is a
big pain because you have to install lots of other stuff first.

So, I rebuilt GCC and re-installed it (one more test to my mind), then
ran make check - except it didn't work and nothing else worked because
the re-install crashed and burned.  Most of the stuff that should have 
appeared in /usr/lib/gcc-lib just wasn't there.  I played with switches
and options and flags and so on for hours without any luck, and it all
turned out to be this stupid tar business.  Make was working, but make
install failed because it needs tar and I was using the "wrong" version
of tar; s-tar instead of GNU tar.

> But if you've fixed it, then I'm not going to worry :)

Well, your brief attention was appreciated anyway :)  Sorry to waste any
of your time.

-- 
Steve Bougerolle
Creek & Cowley Consulting

http://www.creek-and-cowley.com

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list