Pure-LFS script problems with devfs

Thomas Kalla xTx at gmx.de
Wed Apr 2 04:43:59 PST 2003


Hi,

first I'd like to thank you: Great work! Great stuff! =)

I tried the scripts (Versions 2.2.3, 2.2.4, 2.2.5 - now running), and run 
exactly into the same problem as Martin Imobersteg 
(http://archive.linuxfromscratch.org/mail-archives/lfs-dev/2003/03/0312.html).

The missing file is the dynamic linker (ld-linux.so.2) which is called within 
the gengenrtl binary. I looked thorugh the logs and found out that the 
installation of binutils in ch6 failed which was the result of errors during 
the installation of glibc in ch6. The problem is that the scripts don't 
detect devfs properly. This is th result of df -T /dev on my host:

bash-2.05$ df -T /dev
Filesystem    Type   1k-blocks      Used Available Use% Mounted on
-                -           0         0         0   -  /dev
bash-2.05$

I propose to look for devfs in /proc/mounts. Replacing the line

df -T /dev | grep devfs > /dev/null 2>&1 &&

with 

cat /proc/mounts | grep devfs > /dev/null 2>&1 &&

in both scripts (ch5 and ch6) solved the problem for me.


Another proposal (not related to devfs) is to unset CFLAGS and CXXFLAGS 
within the scripts, I forgot it to do before running the scripts for the 
first time and realized that first while I was looking through the logs - it 
would be just one step to ensure a clean build ;-)

Due to the fact that my host distro is quite old (it's a two year old LFS 
*g*), I had to update grep and gawk. The old grep (v 2.4.*) didn't build the 
list of packages in at the beginning of ch5-build correctly and there were 
errors in glibc-initial logs because of missing gawk (the distro had mawk 
installed). Nothing spectacular indeed, but maybe it's useful for somebody..

Cheers,
Tom

BTW: I'm not on the list, CC me. Thanx
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list