Glib-3.2.1 error using Pure LFS

Greg Schafer gschafer at zip.com.au
Sat Apr 5 19:29:52 PST 2003


On Thu, Apr 03, 2003 at 03:43:31AM +0100, Michael Villeza wrote:
> 
> Hi all, 
> 
> I'm following Pure LFS. Everything was fine until Chapter 5 - Installing glibc. I followed the commands: 

<snip>

> configure stops with error message ***These critical programs are missing or too old*** 
> 
> 
> I noticed during configure that it checked the versions for gcc and make, my gcc is 3.2.1 while my make is 3.78.1. I already installed make-3.80 as an lfs user, but glibc configure still sees make 3.78.1. But if I run make -v, it's already make-3.80 although the host system is still make-3.78.1.

Hmmm, interesting. I just checked the configure for glibc-2.3.2 and it
indeed does seem that make-3.78.1 is too old for glibc. You've done the
right thing by installing a newer make into /stage1.

But I fail to see why the configure script would not select the 1st one
found in the path.

It looks like you can override the configure script by using the "MAKE"
environment variable. Something like below might do the trick:-

  MAKE=/stage1/bin/make CFLAGS="-O2 -pipe" ../glibc-2*/configure blah...

Greg
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list