fstat64 filesize problem

Kelledin kelledin+LFS at skarpsey.dyndns.org
Thu Feb 13 14:26:13 PST 2003


On Thursday 13 February 2003 02:47 pm, Vidar Hoel wrote:
> > It sounds like you're stumbling on a "large-file support"
> > issue. Compile the program with -D_FILE_OFFSET_BITS=64
> > -D_LARGEFILE_SUPPORT -D_LARGEFILE64_SUPPORT, and this
> > problem should go away.  You'll know the problem is gone if
> > sizeof(buf.st_size)==8.
>
> Well, I tried this, but no dice. I still have the same
> problem.

Damn...you may carve the word "DUMBASS" on my forehead now. :(  I 
gave you the wrong info!

That's -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE 
-D_LARGEFILE64_SOURCE.  I even knew that, but somehow the typing 
flowed from my fingers as -D_LARGEFILE[64]_*SUPPORT*.  Sorry... 
:(

In any event, I checked that out on my end, and passing the 
(correct) -D flags seems to fix the problem in your test 
program.  My glibc is close to the LFS-CVS glibc (2.3.1)--I just 
add some minor patches for LSB-compliant library naming+ 
blowfish-crypt support, and I configure it with 
--enable-kernel=2.4.0.

BTW, do NOT use --enable-kernel=current, as it introduced some 
obscure brokenness last time I tried it.

> And, now I found a worse error: Trying to copy a file
> (via scp) from this LFS-box, it would go in a loop and copy
> the file again and again

Now that issue...well, I'm having trouble reproducing it, sorry.  
That task seems to work fine here, no matter what glibc is on 
which host.

-- 
Kelledin
"If a server crashes in a server farm and no one pings it, does 
it still cost four figures to fix?"

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list