fstat64 filesize problem

Vidar Hoel vhoel99 at grm.hia.no
Thu Feb 13 15:33:37 PST 2003


On Thu, Feb 13, 2003 at 10:23:23PM +1100, Greg Schafer wrote:
> On Thu, Feb 13, 2003 at 08:50:52AM +0100, Vidar Hoel wrote:
> > Hi,
> > 
> > To illustrate my problem, I have created a little program to open one
> > file:
> 
> <snip>
> 
> > I have tried to recompile both gcc, glibc and strace. I have tried to
> > recompile reiserfsprogs without optimizations, to create a new
> > partition with both ext3 and reiserfs to see of that helped, but no.
> 
> Did you run "make check" for glibc?

When I ran configure in glibc, I got this:
configure: warning: 

*** These auxiliary programs are missing or incompatible versions:
autoconf 
*** some features will be disabled.
*** Check the INSTALL file for required versions.

But I ignored it, because the INSTALL-file didn't say I needed it,
so..

After I issued a "make", I ran "make check". I got one error:

gcc tst-atime.c -c -O2 -Wall -Winline -Wstrict-prototypes
-Wwrite-strings -g      -I../include -I.
-I/usr/src/lfs/glibc-build/libio -I.. -I../libio
-I/usr/src/lfs/glibc-build -I../sysdeps/i386/elf
-I../linuxthreads/sysdeps/unix/sysv/linux/i386
-I../linuxthreads/sysdeps/unix/sysv/linux
-I../linuxthreads/sysdeps/pthread -I../sysdeps/pthread
-I../linuxthreads/sysdeps/unix/sysv -I../linuxthreads/sysdeps/unix
-I../linuxthreads/sysdeps/i386/i686 -I../linuxthreads/sysdeps/i386
-I../sysdeps/unix/sysv/linux/i386 -I../sysdeps/unix/sysv/linux
-I../sysdeps/gnu -I../sysdeps/unix/common -I../sysdeps/unix/mman
-I../sysdeps/unix/inet -I../sysdeps/unix/sysv/i386
-I../sysdeps/unix/sysv -I../sysdeps/unix/i386 -I../sysdeps/unix
-I../sysdeps/posix -I../sysdeps/i386/i686/fpu -I../sysdeps/i386/i686
-I../sysdeps/i386/i486 -I../sysdeps/i386/fpu -I../sysdeps/i386
-I../sysdeps/wordsize-32 -I../sysdeps/ieee754/ldbl-96
-I../sysdeps/ieee754/dbl-64 -I../sysdeps/ieee754/flt-32
-I../sysdeps/ieee754 -I../sysdeps/generic/elf -I../sysdeps/generic  -I
/lib/modules/2.4.20/build/include -D_LIBC_REENTRANT -include
../include/libc-symbols.h   -DNOT_IN_libc -DIS_IN_tests
-D_IO_MTSAFE_IO -o /usr/src/lfs/glibc-build/libio/tst-atime.o

gcc -nostdlib -nostartfiles -o
/usr/src/lfs/glibc-build/libio/tst-atime
-Wl,-dynamic-linker=/lib/ld-linux.so.2   -Wl,-z,combreloc
/usr/src/lfs/glibc-build/csu/crt1.o
/usr/src/lfs/glibc-build/csu/crti.o `gcc --print-file-name=crtbegin.o`
/usr/src/lfs/glibc-build/libio/tst-atime.o
-Wl,-rpath-link=/usr/src/lfs/glibc-build:/usr/src/lfs/glibc-build/math:/usr/src/lfs/glibc-build/elf:/usr/src/lfs/glibc-build/dlfcn:/usr/src/lfs/glibc-build/nss:/usr/src/lfs/glibc-build/nis:/usr/src/lfs/glibc-build/rt:/usr/src/lfs/glibc-build/resolv:/usr/src/lfs/glibc-build/crypt:/usr/src/lfs/glibc-build/linuxthreads
/usr/src/lfs/glibc-build/libc.so.6
/usr/src/lfs/glibc-build/libc_nonshared.a -lgcc `gcc
--print-file-name=crtend.o` /usr/src/lfs/glibc-build/csu/crtn.o
GCONV_PATH=/usr/src/lfs/glibc-build/iconvdata LC_ALL=C
/usr/src/lfs/glibc-build/elf/ld-linux.so.2 --library-path
/usr/src/lfs/glibc-build:/usr/src/lfs/glibc-build/math:/usr/src/lfs/glibc-build/elf:/usr/src/lfs/glibc-build/dlfcn:/usr/src/lfs/glibc-build/nss:/usr/src/lfs/glibc-build/nis:/usr/src/lfs/glibc-build/rt:/usr/src/lfs/glibc-build/resolv:/usr/src/lfs/glibc-build/crypt:/usr/src/lfs/glibc-build/linuxthreads
/usr/src/lfs/glibc-build/libio/tst-atime  >
/usr/src/lfs/glibc-build/libio/tst-atime.out

make[2]: *** [/usr/src/lfs/glibc-build/libio/tst-atime.out] Error 1
make[2]: Leaving directory `/usr/src/lfs/glibc-2.3.1/libio'
make[1]: *** [libio/tests] Error 2
make[1]: Leaving directory `/usr/src/lfs/glibc-2.3.1'
make: *** [check] Error 2

But, if I typed in the these commands again, it worked. And I do not
think this has anything to do with my problem, but, you never know :-)

I have also tried this program on several different boxes today, both
with and without DevFS. And with different versions of GCC, Glibc and
the kernel. I also tried the 2.4.18 and 2.4.20 kernel.

And now I see that scp (from the LFS-box) is also corrupt, he sees no
end of the file, he just starts over and over...

So, I hope you have more ideas or suggestions. Thanks anyway.

--
Vidar Hoel - vhoel99 at grm.hia.no
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list