Make check again

Arjan Oosting ajoostin at students.cs.uu.nl
Sun Feb 16 13:49:10 PST 2003


Arjan Oosting wrote:
> Greg Schafer wrote:
> 
>>>     === gcc tests ===
>>>     FAIL: gcc.dg/format/c90-printf-1.c %s with NULL (test for 
>>> warnings, line 236)
>>>     FAIL: gcc.dg/format/c90-printf-1.c (test for excess errors)
>>
>>
>>
>> Those failures are probably due to your buggy expect package:-
>>
>> http://gcc.gnu.org/ml/gcc/2002-08/msg01069.html
> 
> Will apply patch and see what happens
Worked like a charm!

>>> glibc 2.3.1 fails the test-lfs test (something with large filesystem 
>>> support):
>>>     Timed out: killed the child process but it exited 0
>>>     make[2]: *** [/tmp/build/glibc-build/io/test-lfs.out] Error 1
>>>     make[2]: Leaving directory `/tmp/build/glibc-2.3.1/io'
>>>     make[1]: *** [io/tests] Error 2
>>>     make[1]: Leaving directory `/tmp/build/glibc-2.3.1'
>>>     make: *** [check] Error 2
>>
>>
>> See above. This is a problem. Glibc's test suite should always pass.
Seemed to be a timeout issue, mak check waited to short for this test to 
finish (maybe due to reiserfs filesystem or high system load/old 
machine). Made a small change to the source of the test, and it worked!

Changed glibc-2.3.1/io/test-lfs.c from
...
/* We might need a bit longer timeout.  */
#define TIMEOUT 20 /* sec */
...

to

...
/* We might need a bit longer timeout.  */
#define TIMEOUT 60 /* sec */
...

Because 'make check' continues after the last failed test, you need to 
do a 'make tests-clean' between two 'make check's to make sure a tests
are succesfull.
>>> binutils 2.13.2.1 fails  in one ld-bootstrap test:
>>>        FAIL: bootstrap with --static
Still fails, see previous post for details. Does somebody know what's 
going wrong?

Greetings Arjan

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list