top 3.1.5

Jochen Held joh at acentec.de
Wed Feb 19 10:40:32 PST 2003


On Tue, Feb 18, 2003 at 06:01:19PM +0000, James Iwanek wrote:
> Jochen Held wrote:
> 
> > On Tue, Feb 18, 2003 at 05:29:56PM +0000, James Iwanek wrote:
> >> Jochen Held wrote:
> >> 
> >> > Hi
> >> > 
> >> > Problem:
> >> > Toggle on the wchan-column (pressing "f", "y" ," ") in top leads
> >> > to strange behavior.  This means top don't read any input and
> >> > let the screen glint.  After Ctrl-C the terminal needs a reset
> >> > to work properly.
> >> > 
> >> > This seems to be a lfs-specific bug. I can't reproduce it on
> >> > Debian 3.0 and RedHat 7.2 with a fresh compiled procps-3.1.6.
> >> > But a static top compiled on Debian shows the same behavior on
> > I'm inattentive. I have to write what I mean!
> > But *this* static top ....
> >> > my LFS.
> >> > 
> >> > System:
> >> > + post LFS-4.0 cvs
> >> > + kernel 2.4.20
> >> > + gcc 3.2
> >> > + libc 2.2.5
> >> > + libncurses 5.3
> >> > + proc-ps 3.1.5
> >> > 
> >> > Question:
> >> > Can anybody reproduce this ?
> >> > Any explanations ?? patches ???
> >> > 
> >> > Jochen
> >> > 
> >> 
> >> i suggest you update to procps-3.1.6 ;-)
> >> 
> >> -----
> >> Jay
> >> --
> > I did. But this makes no difference
> > 
> > Jochen
> > 
> 
> you could always try an older version.....
> 
> google for procps-2.0.11: that might work
> 
> -----
> Jay
I downgrade to procps-2.0.7 (as in LFS 4.0).
No more strange behavior.

But procps-2.x and procps-3.x are different projects
and "Version 3 includes a rewritten top" as
http://procps.sourceforge.net/ says.
So I still believe there is a bug in top-3.1.x.

Jay thanks for the suggestions

Jochen
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list