pure_lfs ch 5 scripts error out

Nathan Ladd nathanladd at yahoo.com
Fri Feb 28 21:02:06 PST 2003


I built pure lfs ch 5 on my own a while back (though many changes have 
been made since).  I've tried the ch 5 scripts twice and have gotten 
the same error twice.  Here's the screen output:

### Glibc 2.3.1 - initial - Fri Feb 28 21:38:16 CST 2003 ###
<snip>
 o ALL OK
### Binutils 2.13.2.1 - Static Pass 2 - installing linker scripts - Fri 
<snip>
 o ALL OK
Unpacking /home/nathan/LFS/tarballs/gcc-3.2.2.tar.bz2
 o gcc-3.2.2 unpacked successfully
### Gcc 3.2.2 - initial (shared) - Fri Feb 28 22:19:38 CST 2003 ###
 o Configure OK
 o Build OK
./build-ch5-1.0.0.sh: line 1766: syntax error: unexpected end of file

After that shared gcc 3.2.2, nothing happens and the entire rest of the 
script apparently gets skipped.  I don't know the mechanics of how 
things are logged, and I checked some of the gcc (non static) logs and 
didn't see anything except in testlogs/gcc-init.log:

if [ -f ${rootme}/../expect/expect ] ; then  \
   TCL_LIBRARY=`cd .. ; cd ../../gcc-3.2.2/gcc/../tcl/library ; pwd` ; \
    export TCL_LIBRARY ; fi ; \
runtest --tool g++ )
/bin/sh: line 1: runtest: command not found
make[2]: [check-g++] Error 127 (ignored)
make[2]: Leaving directory `/stage1/src/gcc-3.2.2-init-build/gcc'
make[1]: Leaving directory `/stage1/src/gcc-3.2.2-init-build'

And then everything stops.  I didn't tell it to build the dejagnu 
testing stuff (didn't bother to d/l the packages).  Can anyone lend a 
hand here?  I'm bad with scripts; I usually do things by hand because I 
dislike getting my system and the system the scripts expect to meet 
eachother halfway.

-- 
Cheers,
Nathan Ladd (ThanatosNL)
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list