findutils-4.1 compilation error

Kelledin kelledin+LFS at skarpsey.dyndns.org
Thu Jan 9 12:18:25 PST 2003


On Thursday 09 January 2003 09:36 am, Timothy Bauscher wrote:
> On Thu, Jan 09, 2003 at 04:32:10PM +0100, Tobias St?ckmann 
wrote:
> > I have following problem by compiling static findutils-4.1.
> > I have used following commands on an lfs-2002-12-28
> > host-system:
> >
> > This problem will be removed, if I change CPPFLAGS back to:
> > # CPPFLAGS="-Dre_max_failures=re_max_failures2" \
>
> Check the archives for a findutils patch submitted yesterday,
> on lfs-dev. Also note that this is bug 465.
>
> http://bugs.linuxfromscratch.org/show_bug.cgi?id=465
>
> I think I'll remove the flag today, at least temporarily.
> It seems to be causing more trouble than it's worth. Thanks
> for the bug report.

How odd.  Must be some quirk of older libc's--the problem didn't 
occur on my system.  Then again, I'm building LFS off of LFS.

If you have the time, could you try the attached patch in Ch. 5?  
It _should_ fix the problem and allow you to keep the 
-D_GNU_SOURCE flag.  If so it can probably just be merged with 
the main LFS-findutils patch.  If not...well, the -D_GNU_SOURCE 
bit isn't really necessary for x86.

-- 
Kelledin
"If a server crashes in a server farm and no one pings it, does 
it still cost four figures to fix?"

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list