findutils-4.1 compilation error

Mark Lee mplee at shaw.ca
Thu Jan 9 18:02:05 PST 2003


On Thursday 09 January 2003 18:53, you wrote:
> On Thu, Jan 09, 2003 at 05:57:25PM -0700, Mark Lee wrote:
> > > This isn't exactly true.  I just attempted to compile findutils on my
> > > IBM RS/6000 43P-133, which is of PPC arch.  I have Debian 2.2r7 on
> > > there for now since I have not yet done the LFS on it, but without the
> > > -D_GNU_SOURCE it compiled just fine.  So as far as it fixing for
> > > non-x86, this is not entirely true at all, Maybe tomorrow or something,
> > > I'll try it on my Sun Sparcsation 10, plain ol' sparc arch there.
> >
> > Try the patch I posted yesterday (or the day before). I think that should
> > make it work.
>
> The point wasn't that it worked without -D_GNU_SOURCE
> but that it worked without that flag on something non-x86.
> Pinski didn't say anything about -D_GNU_SOURCE breaking
> compilation.

Ok, I see what you mean. I think this is because the -D_GNU_SOURCE exposes all 
of the gnu extensions, so name conflicts are more likely. But, if you get the 
package to work with the _GNU_SOURCE, than it will be more likely to work on 
non-x86 systems (which I think is why it was added). 

My patch should do the second part (getting it to work with -D_GNU_SOURCE). I 
think in general, the _GNU_SOURCE is always good practice (in gnu software), 
but you have to make sure it doesn't break anything (which in this case it 
did).

Mark Lee
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list