My LFS-system is broken, or.....

Greg Schafer gschafer at zip.com.au
Wed Mar 19 03:13:26 PST 2003


On Wed, Mar 19, 2003 at 11:25:38AM +0100, Vidar Hoel wrote:
> On Tue, Mar 18, 2003 at 06:44:01PM -0600, Kelledin wrote:
> > On Tuesday 18 March 2003 05:36 pm, Vidar Hoel wrote:
> > > They then found "the cause of the error is the same: size_t is
> > > being seen as undefined by autoconf and being redefined as
> > > unsigned.  I don't see anything in the log to explain why
> > > that's happening though. In fact, all of those type tests
> > > (mode_t, off_t, pid_t) I would expect to pass on Linux."
> > >
> > > Neither I nor the mozilla-team seems to find out what is
> > > wrong, so I really hope you can check out the bug-page and
> > > come with suggestions.
> > 
> > Could you possibly post your config.log (should be in the root of 
> > the mozilla source tree)?  I only have gcc-3.2.1, but I might be 
> > able to investigate this some anyways.
> 
> They were supposed to go into the first post, but as always...
> 
> Here are the logs from ./configure, the config.log and a test-program
> (and its output) from the mozilla-team.

I notice this in the logs:-

configure:3974: gcc -o conftest    conftest.c -ldnet   1>&5
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.2/../../../../i686-pc-linux-gnu/bin/ld:
cannot find -ldnet

On my system it says:-

configure:3974: /opt/gcc-3.2.2/bin/gcc -o conftest    conftest.c -ldnet
1>&5
/usr/bin/ld: cannot find -ldnet

That path to ld indicates you haven't installed your system by the book.

Just how many compiler and binutils installations do you have on this
system and have you upgraded them since the initial LFS build?

Greg
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list