possible bug in pure lfs

James Iwanek chthon at chthon-uk.com
Mon Mar 24 02:57:53 PST 2003


Ryan.Oliver at pha.com.au wrote:

> 
> OK, the missing autoconf/autoheader/automake differences are generally not
> an issue (we haven't installed them ch5 before we build binutils).
> 
> One question, your host system did have bison/flex didn't it?
> And did they install correctly in ch5 ???
> 
> Most differences concern these not being found correctly ch5.
> 

the hint never said anything about installing bison & flex in chapter 5!

that might just be the problem ;-)

> The use of version specific stuff and missing the tooldir stuff ( which
> AFAICT installs binutils stuff soley into $prefix/bin instead of also in
> $prefix/TARGET-TRIPLE/bin ) should not affect the build.

k

> 
> The linker is being found correctly during each pass ( first in /stage1

good

> then /usr ) and c++ isn't being used...

is that a bad thing?

> 
> Hmmm may want to check that the mmap patch applied correctly too...

re patching the gcc souce tells me that it was
looking at that i found out that for some reason gcc was built in its own
source directory instead of gcc-build - this may be the problem

> 
> Will have to take a closer look when I get home but do check the builds of
> flex/bison...
> 
> Hope this helps somewhat :-/
> Let me know how you go...
> Ryan

im doing ANOTHER full build today (with bison & flex in ch5) - ill keep you
updated

> 
> 

-- 
Jay
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list