Update to current packages or PLFS first?

Greg Schafer gschafer at zip.com.au
Mon May 5 20:15:06 PDT 2003


On Wed, Apr 30, 2003 at 04:28:41PM +1000, Ryan.Oliver at pha.com.au wrote:
> With the PLFS builds you'll find most stuff just builds, even the
> development stuff.

G'day Ryan


> At present
>  - no changes reqd for gcc-3.3 CVS (apart from not using the mmap patch)

You sure about that? Last time I tried a gcc-3.3 build when coming from a
glibc-2.2.5 based system, I had grief due to the fact that "__thread" is now
a gcc keyword (it conflicts with the old 2.2.5 based `bits/sigthread.h').

Fixincludes takes care of the issue but we are disabling fixincludes. I'm
yet to figure out the best (cleanest) way to handle it.

Greg
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list