coreutils - tail -f broken ???

Greg Schafer gschafer at zip.com.au
Wed May 7 22:34:07 PDT 2003


On Thu, May 08, 2003 at 03:09:57PM +1000, Ryan.Oliver at pha.com.au wrote:
> 
> > I cannot find any mention of "_POSIX2_VERSION" in the gcc-3.3 source so I
> > don't really know what is going on.
> 
> Its set in posix/unistd.h ( included bu <unistd.h> )
> >From Glibc CVS 20030404
> #define _POSIX2_VERSION 200112L

Ahh, mystery solved.

> Looks like it'll only affect us doing CVS glibc builds, but it is a gotcha
> thats going to have to be noted for future reference...

Not only glibc CVS, but also glibc-2.3.3 when it comes out..

> So it looks like we still have to update every package we find and fix ALL
> instances of the above, or downgrade our posix conformance when using glibc
> cvs.

Indeed. But just setting _POSIX2_VERSION to the old value in the environment
might be enough to work around the problem..

Ahh, the joys of living on the cutting edge :-)

Greg
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe lfs-dev' in the subject header of the message



More information about the lfs-dev mailing list